This project has moved and is read-only. For the latest updates, please go here.

Ogama 4.5 Sql error that was not present on Ogama 4.4

Jun 20, 2014 at 7:29 PM
Hello,
I've been using Ogama 4.4 with no problems.
However when updating to Ogama 4.5 version I used to get the following error:

Could not load file or assembly 'Microsoft.SqlServer.SqlClrProvider.Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.

It's odd because on 4.4 the server works with no problem whatsoever. I used to get the same error on both 4.5 32 and 64bit versions.

I got MS Framework 4 and 3.5 sp1 installed (and updated), as well as SQLEXPRESS 2014 and 2008, and the C++ dependencies. I repaired the SqlClrProvider to be sure that nothing was wrong and installed SQL Shared Management Objects also.

But 11.0.0 = SQL Server 2012 so...

To whoever has the same problem you have to install the Shared Management Objects package from SQL 2012 available here. It is the SharedManagementObjects.msi.

I've been looking around the internet a lot to find this and thought it would be useful to be here on Ogamas codeplex.

Cheers
Jun 27, 2014 at 8:02 PM
Edited Jun 27, 2014 at 8:03 PM
Hi;

I have same problem with you .Did you solve it. If yes. Could you pleae help me?

Thansk a lot
Jun 27, 2014 at 8:09 PM
Edited Jun 27, 2014 at 8:09 PM
Yes.
If you have a 32 bit System download this file
If you have a 64 bit System download this file
Jun 27, 2014 at 8:16 PM
Thank you very much:-) I am writing and urgently I have to analyse my data set. So I have to solve asap this problem.

There are few of sql types of 2012 as you seen below.. Could you please share sql 2012 with me. I have 64 bit system .


ENU\x64\SQLEXPR_x64_ENU.exe
132.3 MB

ENU\x64\SQLEXPRADV_x64_ENU.exe
1.3 GB

ENU\x64\SQLEXPRWT_x64_ENU.exe
669.9 MB

ENU\x64\SqlLocalDB.MSI
33.0 MB

ENU\x64\SQLManagementStudio_x64_ENU.exe
600.2 MB

ENU\x86\SQLEXPR_x86_ENU.exe
116.7 MB

ENU\x86\SQLEXPR32_x86_ENU.exe
101.5 MB

ENU\x86\SQLEXPRADV_x86_ENU.exe
1.3 GB

ENU\x86\SQLEXPRWT_x86_ENU.exe
706.1 MB

ENU\x86\SqlLocaLDB.MSI
27.8 MB

ENU\x86\SQLManagementStudio_x86_ENU.exe
614.9 MB

Warm wishes
Jun 27, 2014 at 8:23 PM
I'd say for you to install the SQL Server 2014 Express directly from microsoft's website.
All you'll need is a hotmail or msn email address.


http://msdn.microsoft.com/en-us/evalcenter/dn434042.aspx,

After you install all of it then you have to install the files I presented previously.
Jun 27, 2014 at 9:10 PM
Thank you very much :-)
Jun 28, 2014 at 7:29 PM
Hi, sorry for having trouble with the SQL Connection. We are trying to get rid of it, cause a simple sqlite database will do the job also, but that´s what I realized after most of ogama was written, and is hard to change. Stay tuned, or help us by getting your hands on the code.
Thanks for the solution with the shared Management Objects package also!
Adrian
Jul 4, 2014 at 1:26 PM
Hi all,

is it possible to run Ogama 4.5 somehow now? I tried to install different versions of SQL server and it still doesnt work.

Thanks for an answer.
Aug 20, 2014 at 10:58 AM
Hi Sweeney,

I had success installing SQL Server Express 2014 and Shared Management Objects 2014 with Windows 7, 64 Bit.
Except for the Video Stimuli Functions I had full functionality.

Best,
Daniel

PS: It might be wise to name your SQL Server SQLEXPRESS , as this is the standard in Ogama. Be sure you activate file access.
Oct 22, 2014 at 7:24 PM
Edited Oct 22, 2014 at 7:27 PM
I found a workaround to most problems I've had with SQL Server and which also allows skipping the 2GB+ install of SQL Server + Utils.
Before you read on: this requires small changes to the Ogama source code. So it will only work if you are able to compile and run Ogama yourself.

This alternative relies on the command-line tool sqllocaldb.exe which can usually be found in a location like "C:\Program Files\Microsoft SQL Server\110\Tools\Binn", if you happen to have recent version of Visual Studio installed.
If you don't have it yet, you can grab the LocalDB package from http://www.microsoft.com/en-us/download/details.aspx?id=29062 (ENU\x86\SqlLocaLDB.MSI or ENU\x64\SqlLocalDB.MSI).

Code changes:
\OgamaPDB\Properties\ExperimentSettings.cs:189
'this.sqlInstanceName = "SQLEXPRESS";' -> 'this.sqlInstanceName = ".\SQLEXPRESS";'
\OgamaPDB\Properties\ExperimentSettings.cs:783
'usedConnection = @"Data Source=.\" + this.sqlInstanceName + ";Initial Catalog=" +
this.experimentName + ";Integrated Security=True;User Instance=True;Connection Timeout=30";'
->
'usedConnection = @"Data Source=" + this.sqlInstanceName + ";Initial Catalog=" +
this.experimentName + ";Integrated Security=True;Connection Timeout=30";'
\OgamaPDB\Properties\ExperimentSettings.cs:799
'string usedConnection = @"Data Source=.\" + this.sqlInstanceName + ";Integrated Security=True;User Instance=True;Connection Timeout=30";'
->
'string usedConnection = @"Data Source=" + this.sqlInstanceName + ";Integrated Security=True;Connection Timeout=30";'

After you made sure that you have said "sqllocaldb.exe" and made the code adjustments:
  • Run a sqllocaldb: Start a command prompt ("cmd") as administrator (right-click the link) and run the following commands (without the ' ' marks); [FIRST TIME ONLY] 'sqllocaldb c "SQLEXPRESS"'; 'sqllocaldb s "SQLEXPRESS"'; 'sqllocaldb i "SQLEXPRESS"' [you can actually pick any consistent name for your db]
  • From the output of the last command copy the pipe ala "np:\.\pipe\LOCALDB#SH123456\tsql\query" and paste it into the sql instance name window of Ogama
  • To stop the db run: 'sqllocaldb p "SQLEXPRESS"'
This simply removes the leading ".\" in the SQL Data Source string, thus enabling the use of named pipes, but requiring the database name to start with a ".\" when using a full-blown SQL Express Server.
AVosskuehler: Given some testing, this might be a wort-while fix for Ogama?
Nov 1, 2014 at 3:14 PM
Hi there,
thanks sanok for providing some insights in Workarounds when sqlserver does not work as expected.

In the future I whish to get rid of the SQL Server and move to a simple sqlite file. No ogama user I know needs more than the features sqlite will provide, and deployment and handling will be very much easier.
But this step is not the easy to have, and we will need some old to new database converter... Rüdiger had some plans using NHibernate but has not finished yet.

Regards, Adrian
Dec 4, 2014 at 2:33 AM
Edited Dec 4, 2014 at 6:44 AM
Hi all,
i have Sql 2005 installed so i install ogama version 2.7 but i cannot connect to my sql, just said connection failed when i klik test connection..

please help me..
thank you..
Dec 5, 2014 at 5:47 PM
Hi Fatrafirdaus;

If you well check the forum. You can find which sql is compatible with 2.7

Best

Hakan
Apr 15, 2015 at 8:56 PM
In the meantime I found some users solved the 'Microsoft.SqlServer.SqlClrProvider' error by installing SQL Server 2012 not 2014.
Adrian
Apr 22, 2015 at 6:21 PM
Hi there,
Thanks adreno2342.
May 15, 2015 at 2:06 PM
Ogama V5 will get rid of the sqlexpress problems, cause it depends on sqlite local databases. Only to convert older Projects you would Need to have the SQL instance running once.