This project has moved and is read-only. For the latest updates, please go here.

Ogama and EyeLink

Mar 16, 2012 at 7:19 PM

Hi!

I'm having trouble with the import data assistant in Ogama. I have registration data from an Eye Link II (Sr research), but when I try to import them  into Ogama (through the ASCII file), several errors come (no images specified, and others). Does anyone have ever used Ogama with these Eye tracker, and could then tell me how to import correctly the data?

Thanks

Mar 19, 2012 at 2:54 PM

Hi, 

I succesfully imported EyelinkII log files some time ago, so I know that there is a way to to it, but that is not that easy. Send me an example log file -> adrian@ogama.net and I can surely help you.

Regards, Adrian

Mar 19, 2012 at 6:37 PM

Thank you Adrian!

I've sent you an email with the log files.

Best regards, Roberta

Mar 19, 2012 at 7:59 PM

Hi Roberta,

Using a sample file AND an event file will not work during import for Ogama.
You have to export the eyelinks .edf file into one file including the samples AND the events, like this:

2631437   624.3   322.3  3046.0 .....
2631438   624.8   318.9  3046.0 .....
2631439   629.7   316.5  3050.0 .....
MSG 2631439 1 !V DRAW_LIST ../../runtime/dataviewer/1/graphics/vcl_3452529488282020678.vcl
2631440   633.9   316.1  3043.0 .....
2631441   638.2   315.7  3037.0 .....
2631442   650.3   314.1  3038.0 .....

not necessarily including the EFIX SSAC ESAC SFIX values. So the MSG lines with the next stimulus should be in between the samples.

Then you may use the "use MSG lines containing MSG" in step 4 of the import assistant and also for the step 5.
Hope this helps, Adrian

Mar 22, 2012 at 2:56 PM
Hi Adrian,
I've tried with the solution you told me, but I still have errors with the import assistant. Could you please tell me the exact procedure to follow? Maybe I'm making some errors in the first steps. I've attached the Sample&Event logfile.
This is the error logfile.

--------------------------------------------------------------------------------
Error on giovedì 22 marzo 2012, 14:38:12
- Something failed during import.
Please try again with other settings.
Error: Index non compreso nell'intervallo. Richiesto valore non negativo e minore della dimensione dell'insieme.
Nome parametro: index
--------------------------------------------------------------------------------

Thanks again.
Best regards.
Roberta





2012/3/19 avosskuehler <notifications@codeplex.com>

From: avosskuehler

Hi Roberta,

Using a sample file AND an event file will not work during import for Ogama.
You have to export the eyelinks .edf file into one file including the samples AND the events, like this:

2631437 624.3 322.3 3046.0 .....
2631438 624.8 318.9 3046.0 .....
2631439 629.7 316.5 3050.0 .....
MSG 2631439 1 !V DRAW_LIST ../../runtime/dataviewer/1/graphics/vcl_3452529488282020678.vcl
2631440 633.9 316.1 3043.0 .....
2631441 638.2 315.7 3037.0 .....
2631442 650.3 314.1 3038.0 .....

not necessarily including the EFIX SSAC ESAC SFIX values. So the MSG lines with the next stimulus should be in between the samples.

Then you may use the "use MSG lines containing MSG" in step 4 of the import assistant and also for the step 5.
Hope this helps, Adrian

Read the full discussion online.

To add a post to this discussion, reply to this email (ogama@discussions.codeplex.com)

To start a new discussion for this project, email ogama@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Mar 22, 2012 at 6:42 PM

Hi Roberta,

I found the bug that stopped the succesful import of your file, I fixed it with changset 1c264e8983eb and will be included in the next release.
In the meantime it may be an option for you to remove all lines that have no timestamp from your log file except the MSG lines with the .png file. This should work.

Regards, Adrian

May 31, 2012 at 2:37 PM

I'm still having troubles with the import.. I've installed the last version of Ogama, but this didn't solve the problem. If I import the sample AND event file, ogama will not recognize any data, so I must import only the event file. It works, but the durations of each trial are not correct, because they are higher than they really are (as I can see from the event file, from the differences between stime e etime). It seems that ogama calculate the duration of each trial from each start-time, not considering the end time. How can I solve this?

Thanks again.

Roberta

Jul 1, 2012 at 9:15 PM

Hi Roberta,

you are right, Ogama doesn´t think of empty-time between the trials... sorry for that. It calculates the duration right from the starttime of the next trial. Maybe I can correct this later on.

In the meantime I would suggest to insert In-between trials, that can be ignored after the import. So insert at least one line after the end sample with the next timestamp using another trial id or dummy jpg.

Regards, Adrian