This project has moved and is read-only. For the latest updates, please go here.

SQL Server

Feb 15, 2012 at 2:16 PM


I get the following Error message

"The following error occured: Index was outside the bounds of the array.


If it is the following: 'Failed to generate a user instance of SQL Server due to a failure in starting the process for the user instance. The connection will be closed.'Please delete the folder 'Local Settings\Application Data\Microsoft\Microsoft SQL Server Data\test' in WinXP or 'AppData\Local\Microsoft\Microsoft SQL Server Data\test' on Vista and Windows 7 and try again."


Deleting this folder had no effect. Has anyone a suggestion what I can do?



Feb 15, 2012 at 7:14 PM

Hi Ewald, your error is the "index out of bounds" error not the "failed user instance" error, so deleting the folder does not help. It seems, that your database is corrupted somehow. Are you able to provide the steps to reproduce the error? It should not occur on creating a new experiment?

It would also help if you send me your project folder -> so that I may have a look at the problem.

Kind regards, Adrian

Feb 15, 2012 at 7:39 PM
Edited Feb 15, 2012 at 7:39 PM

Hi. This Error occured on a new installation of ogama (and the sql express server). I tried to start a new experiement and the error occured.

The project folder should therefore be empty but I can check tomorrow.

For sql server I used the default settings.

Only thing that is different to my other installations of ogama is that it is a english windows7 with english sql server.

Kind regards, Ewald




Feb 15, 2012 at 8:35 PM

Does the sql server instance is running (check the running services)? Is it named sqlexpress? Which are the steps to reproduce? Do you have the ability to debug it yourself using visual studio and ogamas sources, it would be of main interest to find the source code line the error occurs. What is the content of the error.log and exception.log files in your appdata folder (subfolder ogama)?

Feb 17, 2012 at 7:08 PM

Hi i have the same problem. i tried to get it to work on to machines and when u try to test the connection it says its okay but when you open or create a project i get the sql error. trid to delete the folder but it makes no difference what so ever. please help !!!!

Feb 18, 2012 at 8:57 AM

I may help you only if you provide more details on it as I wrote in my previous post :-)
Regards, Adrian

Feb 18, 2012 at 10:59 AM

Hi! Sorry, tried to finde someone with programming skills but all our technicans are busy at the moment.

The sql servers seem to be different to my regular installation.

this is the regular one and in the problematic one there are 4 different sql services and one is not running (stopped). I took a screenshot but unfortunately it got lost.

vus: may you validate this?

the error and expecation logs are on the way to you.

Steps to reproduce:

- install ogama

- install sql express (english version)

- try to create an experiment


The server is named SQLEXPRESS but later i also tried to install another sql server and put that name in ogama --> both same effect. Test says connection established successful but when trying to continue the error message came.


Kind Regards


Feb 18, 2012 at 11:00 AM

ok picture cant be posted, i send it.

Feb 18, 2012 at 9:46 PM

Thanks for your additional input, i can not reproduce the error at the moment. The exception log indicates, that ogama cannot attach the database to the running instance.

Are you using profiles with different privileges ? Please try to log on as an administrator and tell me if this helps.

The test connection button succeeds, because it just tests whether there is a running sql instance with that name (and that is ok on your systems). But the test does not include trying to attach a database file (should do this in a next version).

Are you able to attach a database manually using SQL management studio express?

Regards, Adrian

Feb 27, 2012 at 7:53 PM


Sorry for the long response time.

Building externali with Visual Studio a Database works. Ogama starts and working on the project is possible.

A possible work arround could be to programm the projekt on a different PC and export the data to the needed computer. (I will check this tomorrow)

Maybe later this week I can also profide the debugging data you wanted.


Regards, Ewald

Feb 27, 2012 at 8:26 PM

Are you running as an administrator? Recently had issues with sql server under non-admin accounts.

Feb 27, 2012 at 9:41 PM

Difficult question.

According to windows the account has all administrative rights but the installation is a bit odd. We will check this possibility.

Thanks for the work arround for now.

Mar 2, 2012 at 7:46 PM


Finally found it out. You were right with the admin rights (but the account has the admin in general). In the properties of the program you have to click the option "perform as admin".



Mar 3, 2012 at 8:28 PM

Hi Ewald, thanks for your patience! Glad you found a solution. Ogama should also work in non-administrator accounts and rights, will put this on the bug list.